That key is bad

Jan 28, 2015 at 10:42 AM
I'm new to MailChimp so please forgive me if I missed something obvious.

I've created a new API key using a free account at MailChimp but when I try to enter the key into the Orchard MailChimp settings it returns a message That key is bad.

Clicking on the link provided and typing in my credentials takes me to a MailChimp page with the same key on it.

Is there something I've missed ? I'm using the 1.8.1 of Orchard.
Coordinator
Jan 28, 2015 at 11:29 AM
The version of Orchard shouldn't matter.

The API key should look like this:

0000aaaad00a0baa0000600005aa6604-us1

A mixture of letters and numbers, a hyphen and then us, and then a number (probably 1 or 2).

Make sure there are no spaces before of after it in the input box.

This module checks your API key by trying to login using it. The error means it has failed to login, which is probably because the credentials are wrong, but could also be because you don't have an internet connection on your test server.

If you're still having a problem send me a private message with your API key and I'll try logging in and monitor the error messages more closely.
Coordinator
Jan 28, 2015 at 12:08 PM
Found the issue, but it's with a library I'm using.

The issue 'US codes greater than 9 don't work' has been reported on their Codeplex page here:

https://perceptivemcapi.codeplex.com/workitem/7949

Once they've fixed it, you can update their DLL in this module, and I'll do the same and issue a new version.